phpgeo requires at least PHP 7.2.
The 2.x releases require PHP >= 7.0 but don't get feature updates any longer.
The 1.x release line has support for PHP >= 5.4.
phpgeo is best be installed using Composer. Please visit the Composer website website for more information.
To install phpgeo, simply “require” it using Composer:
composer require mjaschen/phpgeo
phpgeo is now ready to be used in your project!
Installation of Development Tools
Most of the development dependencies are managed with Phive.
For that you have to install Phive first. Now a simple
phive install -c fetches all required Phar archives and installs them into the